Performance issues with video history playback

Incident Report for Verkada Command

Resolved

Streaming metrics have remained stable after implementing a fix.
Posted Sep 18, 2025 - 13:21 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 18, 2025 - 10:35 PDT

Monitoring

Verkada has implemented a fix will monitor streaming metrics until they return to baseline.
Posted Sep 18, 2025 - 09:50 PDT

Investigating

Our engineering team is investigating issues with video history loading slowly.
Posted Sep 18, 2025 - 09:03 PDT
This incident affected: Streaming Historical Footage.