Some devices are unable to upgrade firmware

Incident Report for Verkada Command

Resolved

We have resolved an issue with delayed device upgrades caused by an infrastructure resource bottleneck. Devices should continue to process firmware upgrades on their regular schedule.
Posted Apr 01, 2026 - 18:03 PDT

Investigating

We are currently investigating issues with our over-the-air (OTA) firmware upgrade system. Your devices will still function normally while we resolve these issues.
Posted Apr 01, 2026 - 13:51 PDT
This incident affected: Device Claiming.