Some Viewing Stations are offline

Incident Report for Verkada Command

Resolved

We identified an issue affecting Viewing Stations with a non-English locale set. We’ve since shipped a new version, that resolves it.

Symptom: affected customers most likely saw a black screen on their VX.

What we’ve done: went through the list of affected devices, manually updated the ones we could, and verified they’re back to a healthy, streaming state.
Posted Aug 21, 2026 - 16:27 PDT

Update

Our engineers are continuing to work on this issue with high priority. If you have an affected Viewing Station please leave it online so that an update can applied when available.
Posted Aug 20, 2026 - 21:12 PDT

Investigating

Our engineers are investigating an issue causing a small subset of viewing stations to be offline.
Posted Aug 20, 2026 - 20:01 PDT
This incident affected: Viewing Station.