Unable to open chat conversations with Verkada Support

Incident Report for Verkada Command

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:10 PDT

Identified

Our 3rd party provider is currently working through an outage. During this time, users will be unable to contact Verkada Support through chat.

If you need support, reach out to support@verkada.com or give us a call:

North America: +1 (650) 514-2500
Europe: +44 (0)20 3048 6050
Asia / Pacific: +61 (2725) 99300
Posted Oct 20, 2025 - 07:37 PDT
This incident affected: Verkada Support.