Delayed and dropped alert notifications, webhook deliveries, and person/vehicle detection events

Incident Report for Verkada Command

Resolved

This incident has been resolved.
Posted May 15, 2026 - 12:40 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2026 - 11:14 PDT

Investigating

We are investigating elevated latency and intermittent failures affecting alert notifications, webhook deliveries, and person/vehicle/LPR detection events. Webhook deliveries that fail during this period will not be retried. Live video and camera connectivity are not affected.
Posted May 15, 2026 - 09:53 PDT
This incident affected: Events and Notifications and Camera Analytics.